py-pure-client Documentation

Overview

This Python package provides clients that use the Pure1 and FlashArray REST APIs.

Installation
Steps for installing the Python package.
Quick Start
A quick start guide for the Python clients.
FlashArray Reference
A glossary of all interfaces and models used by the FlashArray client.
Pure1 Reference
A glossary of all interfaces and models used by the Pure1 client.

Requirements

The library requires Python 2.7 and higher or Python 3.3 and higher. Third-party libraries are also required.

Community

To learn what other Pure Storage customers are doing with the client, to share an implementation or contribute code, or to interact with Pure Storage, visit the Pure Storage Community.

Changes

See the Changelog for a list of changes to py-pure-client.

License

This code is licensed under the simple BSD 2-Clause License.

See the LICENSE.txt file in the top level of the source tree.